• Boat Banter

    The Best British Boat Forum
It is currently 17 Dec 2018, 03:43

Boat Engines etc - Maintenance and Repair

Mercruiser Power steering

by shibbs » 24 Jun 2018, 20:48

Evening all.
Having had a fantastic weekend out on the boat, i have noticed a slight ( and it is slight) whine from the steering, only just noticeable on turning the wheel above the engine noise. The wheel has also started over time to wobble very slightly on turning to Stbd, ie not a smooth operation as expected, port is normal.
Does anyone have any knowledge of this system and what might be causing this?
The power assisted steering is working as with engine off it is much stiffer as you'd expect but the wobble / jerkiness tells me something may need attention at some point.
It isn't major and as yet not causing any issues, just want to get on top of it before something might fail.

Any ideas anyone?
Stu

Draco 2500 Crystal - Mercruiser 5.7, Alpha one - Chin Chin
User avatar
shibbs
Sub Lieutenant
Sub Lieutenant
 
Posts: 720
Joined: 25 Nov 2014, 20:28
Location: Hampshire

by Ianfs » 25 Jun 2018, 10:22

Quicksilver Extreme

The steering arm in the hydraulic unit is stainless steel entering into an aluminium casing. :o Although there are seals etc. it is particularly vulnerable to dryness and stiffness. It has to be kept greased. Ordinary grease is useless, it had to be a marine high performance grease, not cheap but a little goes a long way.

Quicksilver 101 is the best, if you can still get it, it was very expensive but lasts forever. The new one is Quicksilver Extreme grease as above, not cheap but is very good, if none of these are available use Quicksilver 2-4-C it will work but you may have to wipe it off each season and re-grease.

I hope the whine is the power steering pump having to work harder and not a Gimbal Bearing failing, although I think you replaced yours recently didn't you?

Hopefully this simple fix will sort it out. :)
Ianfs
Captain
Captain
 
Posts: 1743
Joined: 24 Nov 2014, 18:40
Location: Hampshire, by the Sea

by shibbs » 25 Jun 2018, 18:18

Thanks for the advice ian, great help as always!
I didn’t replace the gimbal bearing, I inspected it at the end of last season when I had the leg off and it was fine.
With regard to the whine it does it when the wheel is turned out of gear so assume it will probably be the pump. Certainly haven’t greased it so that may sort it. Will try that and see what the results are.
Typically work is now in the way for the next 3 weeks so she’ll be sitting unused during this lovely weather that’s here. :cry:
Stu

Draco 2500 Crystal - Mercruiser 5.7, Alpha one - Chin Chin
User avatar
shibbs
Sub Lieutenant
Sub Lieutenant
 
Posts: 720
Joined: 25 Nov 2014, 20:28
Location: Hampshire

by shibbs » 20 Jul 2018, 14:45

Finally got down to boat today, applied some grease to the steering actuators etc and problem solved!
Just thought I’d add it on incase anyone else ever has the same problem.
Thanks for the advice!
Stu

Draco 2500 Crystal - Mercruiser 5.7, Alpha one - Chin Chin
User avatar
shibbs
Sub Lieutenant
Sub Lieutenant
 
Posts: 720
Joined: 25 Nov 2014, 20:28
Location: Hampshire


Return to Boat Engines etc - Maintenance and Repair

cron

User Menu